Email invites not reliably delivered
Incident Report for emnify
Resolved
This incident has been resolved.
Posted Oct 31, 2023 - 15:27 UTC
Monitoring
Dear Customers.

Our report to Microsoft regarding the false blocking of those emails has been reviewed and processed.

We can confirm that email delivery is once again successful in its current state.

Thanks a lot
Emnify Support Team
Posted Oct 30, 2023 - 14:25 UTC
Identified
Dear Customers.

We have narrowed down the issue down to users of Microsoft 365. It appears that Microsoft's anti-phishing filters contain a heuristic rule, which falsely classifies URLs used in emails from the emnify portal.

We are working on a fix to remediate this.

Until then, we recommend users who are affected by this to contact their Microsoft 365 administrator to release these emails.

Following the process described in Micrsoft documentation [1], The user should please go to https://security.microsoft.com/quarantine and enter "do-not-reply@emnify.com" into the Search field. After selecting all relevant emails, they should be released to the user using the "Release" action.

[1] https://learn.microsoft.com/en-us/microsoft-365/security/office-365-security/quarantine-admin-manage-messages-files?view=o365-worldwide

Thanks a lot
Emnify Support Team
Posted Oct 30, 2023 - 12:58 UTC
Investigating
Dear Customers,

We are currently looking into reports of email delivery issues from the emnify portal, particularly concerning the reliability of messages like password reset requests and new user invitations, especially for Microsoft 365.

More updates to follow shortly.

Emnify Support Team
Posted Oct 30, 2023 - 11:17 UTC
This incident affected: Portal, API & Data Analytics (User Interface).