Service instability - O2 UK

Incident Report for emnify

Resolved

This incident has been resolved. If you are still experiencing issues, please contact our Customer Support team.
Posted Apr 23, 2025 - 16:36 UTC

Monitoring

O2 UK is operational again. We will be closely monitoring the network over the next few hours.
Posted Apr 23, 2025 - 15:48 UTC

Identified

We confirm stability issues with O2 UK, affecting LTE service only. 2G and 3G remain operational. We have contacted the operator and are currently waiting for a fix to be applied.
Posted Apr 23, 2025 - 12:33 UTC

Investigating

Dear emnify customer,

We are currently investigating a service instability in O2. Devices that attempt to connect to this network may experience issues.

We will publish an update shortly.
Posted Apr 23, 2025 - 12:07 UTC
This incident affected: Network Connectivity (Network Connectivity - Europe).