Service degradation - MTN / Uganda
Incident Report for emnify
Resolved
The incident has been resolved and the service is operational. In case you are still experiencing issues, please submit a request to our Customer Support team.
Posted Jul 16, 2024 - 19:13 UTC
Monitoring
We see successful traffic on MTN Uganda again and devices have already recovered their connection.

We will be monitoring this closely.
Posted Jul 16, 2024 - 16:21 UTC
Identified
We have contacted the operator, and we are waiting for a fix to be applied. In the meantime, the connectivity in the country is guaranteed via Airtel.
Posted Jul 16, 2024 - 09:19 UTC
Investigating
Dear emnify customer,

We are currently investigating a service degradation with MTN Uganda. Devices that attempt to connect to this network may experience issues. Alternative networks (Airtel) are working as expected.

We will publish a new update shortly.
Posted Jul 16, 2024 - 08:15 UTC
This incident affected: Network Connectivity (Network Connectivity - Middle East & Africa).