Service degradation - MTN Uganda

Incident Report for emnify

Resolved

The issue affecting connectivity in MTN Uganda has been fully resolved.

If you experience any further issues, please reach out to our support team.
Posted Apr 17, 2026 - 23:08 UTC

Monitoring

Service connectivity in MTN Uganda has been restored. We are continuing to monitor the situation closely to ensure stability.
Posted Apr 17, 2026 - 23:00 UTC

Identified

We have identified that the reported service degradation affecting connectivity in MTN Uganda is not originating from the emnify platform. We have engaged MTN and are working with them to resolve the issue.

Connectivity on other networks in Uganda remains fully operational.

We will continue to monitor the situation and provide updates as more information becomes available.
Posted Apr 17, 2026 - 18:02 UTC

Investigating

We are currently investigating a service degradation affecting connectivity in MTN Uganda. Our engineering team is actively working to identify the root cause and assess the impact.

We will provide further updates as soon as more information becomes available.
Posted Apr 17, 2026 - 17:53 UTC
This incident affected: Network Connectivity (Network Connectivity - Middle East & Africa).