This incident has been resolved. If you continue to experience any issues, please contact our Customer Support team
Posted Jan 30, 2026 - 21:27 UTC
Monitoring
We are seeing traffic returning to normal levels. As a result, we have unblocked the Telcel network and service is recovering. We will continue to monitor the situation closely
Posted Jan 30, 2026 - 20:35 UTC
Identified
We have contacted Telcel Mexico and are currently awaiting their response. In the meantime, we have temporarily blocked connections to the Telcel network to prevent further attachments, allowing affected SIMs to connect via alternative networks like Movistar or AT&T. We will share another update as soon as more information becomes available.
Posted Jan 30, 2026 - 20:14 UTC
Investigating
We are currently investigating a service degradation impacting Telcel connectivity in Mexico. We will provide an update shortly.
Posted Jan 30, 2026 - 20:03 UTC
This incident affected: Network Connectivity (Network Connectivity - North America).