Billing Preview Page Inconsistency

Incident Report for emnify

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 11:56 UTC

Investigating

Dear Customers,

We are currently investigating an issue where inconsistencies may be observed on the billing preview page for September.

This issue affects the preview data only, and the actual billing is not impacted.

Our engineering team is actively working to identify the root cause and will provide updates shortly.

Thank you for your patience and understanding.

Emnify Support Team
Posted Sep 02, 2025 - 09:25 UTC
This incident affected: Portal, API & Data Analytics (User Interface, API).