Service Degradation - Telstra Australia

Incident Report for emnify

Resolved

Dear emnify Customers,

The incident has been resolved, and network traffic has returned to normal levels.

In case you are still having issues, please reach out to our Support Team via our Help Center.


Kind regards,
emnify Support Team
Posted Mar 11, 2026 - 01:51 UTC

Monitoring

Dear emnify Customers,

Telus has confirmed that a fault with their signaling provider caused the observed LTE and LTE-M service degradation.

Our recent network tests are yielding successful results, and we are observing traffic towards the network beginning to recover.

We will continue to monitor network performance and provide additional updates as needed.


Kind regards,
emnify Support Team
Posted Mar 11, 2026 - 00:16 UTC

Identified

Dear emnify Customers,

We have contacted Telstra Australia regarding the ongoing service degradation and are currently awaiting their feedback.

Alternative LTE networks in Australia (Vodafone and Optus) remain available for connectivity fallback. Meanwhile, LTE-M connectivity in this region is currently provided via the Telstra network only and may therefore remain affected while the issue persists.

We will provide further updates as additional information becomes available.


Kind regards,
emnify Support Team
Posted Mar 10, 2026 - 22:33 UTC

Investigating

Dear emnify customers,

We are currently investigating a service degradation affecting LTE and LTE-M connectivity on the Telstra Australia network. Devices attempting to connect may experience intermittent connectivity issues or may be unable to attach to the network.

We will provide further updates as soon as more information becomes available.


Kind regards,
emnify Support team
Posted Mar 10, 2026 - 22:13 UTC
This incident affected: Network Connectivity (Network Connectivity - Asia-Pacific).