Stats API Degraded Performance

Incident Report for emnify

Resolved

This incident has been resolved
Posted Oct 07, 2025 - 13:50 UTC

Monitoring

A fix has been applied, and the affected data is currently being backfilled. The process is expected to complete within the next few minutes. Our team is monitoring the results to ensure data accuracy and normal operation
Posted Oct 06, 2025 - 21:33 UTC

Identified

The root cause of the Stats API degradation has been identified. A fix is in progress, and we’ll share another update once it has been applied.
Posted Oct 06, 2025 - 17:28 UTC

Investigating

We are currently investigating an issue causing degraded performance in our Stats API. As a result, the portal may display incomplete or inaccurate information. Our team is actively working to identify the cause, and we’ll provide an update as soon as possible.
Posted Oct 06, 2025 - 16:02 UTC
This incident affected: Portal, API & Data Analytics (API, Data Analytics).