Please reach out to our Customer Support team via the help center if you continue to face issues.
Posted Jun 21, 2026 - 07:11 UTC
Monitoring
Our infrastructure provider has implemented a fix, and we confirm that both embedded dashboards and stats API are operational again.
We will continue to monitor closely.
Posted Jun 21, 2026 - 01:02 UTC
Identified
We have identified that the degraded performance is caused by an issue with our infrastructure provider. We are working closely with them to restore normal service as quickly as possible and will provide further updates soon.
Posted Jun 20, 2026 - 22:50 UTC
Investigating
Dear emnify Customers,
We are currently investigating reports of degraded performance affecting the embedded dashboards in the portal and the Stats API. Our team is working to identify the root cause and will provide updates as more information becomes available.
Kind regards, emnify Support Team
Posted Jun 20, 2026 - 22:35 UTC
This incident affected: Portal, API & Data Analytics (API, Data Analytics).