Temporary Portal Usability Issue for Non-English speaking Users
Incident Report for emnify
Resolved
Dear Customers,

This is to inform you that this issue has been resolved.

Please update to the latest version of the user interface when prompted.

Thanks a lot for you patience.
Emnify Support Team
Posted Nov 28, 2024 - 19:31 UTC
Identified
Dear Customers,

This issue has been identified and a fix is being implemented.

Further updates will follow shortly.

Thanks a lot
Emnify Support Team
Posted Nov 28, 2024 - 19:16 UTC
Investigating
Dear Customers,

We are currently experiencing some usability issues with the portal for Non-English speaking users.

Our team is actively investigating the matter and working to resolve it as quickly as possible.

We will provide updates as soon as more information becomes available.

Thank you for your patience and understanding.
Emnify Support Team
Posted Nov 28, 2024 - 18:43 UTC
This incident affected: Portal, API & Data Analytics (User Interface).