Service degradation - Telcel Mexico
Incident Report for EMnify
Resolved
The incident has been resolved and the service is operational. In case you are still experiencing issues, please submit a request to our Customer Support team.
Posted Jun 24, 2022 - 12:43 UTC
Monitoring
We are starting to see successful traffic on Telcel Mexico again and devices have started to recover their connection.

We will be monitoring this closely.
Posted Jun 24, 2022 - 12:12 UTC
Identified
We confirm 2G and 3G issues with Telcel Mexico, affecting devices roaming in that network. We have contacted the operator, and we are waiting for a fix to be applied.

4G/LTE is operational, as well as Movistar as an alternative operator.
Posted Jun 24, 2022 - 08:17 UTC
Investigating
Dear EMnify customer,

We are currently investigating a service degradation in Telcel Mexico. Devices that attempt to connect to this network via 2G and 3G may experience issues.

We will publish a new update shortly.
Posted Jun 24, 2022 - 08:03 UTC
This incident affected: Network Connectivity (Network Connectivity - North America).