We have reached out to Lonestar Liberia and we are awaiting additional updates regarding the root cause and remediation efforts.
As a temporary mitigation measure, connections to the Lonestar network have been blocked to prevent additional device attachments. Affected SIMs should continue to connect through alternative available network (Orange).
We will provide another update as soon as more information becomes available.
Kind regards, emnify Support Team
Posted May 18, 2026 - 07:33 UTC
Investigating
Dear emnify Customers,
We are currently investigating a connectivity issue affecting devices connected via the Lonestar network in Liberia. Customers may experience intermittent connectivity and service degradation.
Our team is actively working with the network provider to identify the root cause and restore normal service as quickly as possible.
We will continue to share updates as more information becomes available.
Kind regards, emnify Support Team
Posted May 18, 2026 - 07:18 UTC
This incident affects: Network Connectivity (Network Connectivity - Middle East & Africa).