Service degradation - Digitel Venezuela
Incident Report for emnify
Resolved
The incident has been resolved and the service is operational. In case you are still experiencing issues, please submit a request to our Customer Support team.
Posted May 23, 2024 - 17:27 UTC
Identified
We confirm 2G & 4G connectivity issues with Digitel Venezuela. 3G service is operational. We have contacted the operator, and we are waiting for a fix to be applied.
Posted May 21, 2024 - 20:33 UTC
Investigating
Dear emnify customer,

We are currently investigating a service degradation in Digitel Venezuela. Devices that attempt to connect to this network may experience issues.

We will publish a new update shortly.
Posted May 21, 2024 - 20:26 UTC
This incident affected: Network Connectivity (Network Connectivity - Central and South America & Caribbean).