Service degradation - Telstra (Australia)

Incident Report for emnify

Resolved

This incident has been resolved.

Our Customer Support team will be closely monitoring this network over the next few days. We will also publish a detailed incident report shortly.

If you are still experiencing issues with Telstra, please contact us.
Posted Mar 28, 2025 - 13:53 UTC

Monitoring

Telstra has made adjustments to the network, and we are already seeing devices gradually reconnecting to the network.

We will be monitoring this closely and will publish a new update shortly
Posted Mar 28, 2025 - 03:49 UTC

Update

Our tests have not yet shown any signs of recovery for the Telstra network. We are actively coordinating with the relevant teams to resolve the issue as soon as possible.

In the meantime, we would like to remind you that Optus and Vodafone remain operational in the country, and standard LTE devices can still connect to these networks.
Posted Mar 27, 2025 - 15:43 UTC

Update

Our tests are still not showing a recovery of the Telstra network. We remain in contact with the responsible teams to resolve the issue as soon as possible
Posted Mar 26, 2025 - 23:22 UTC

Identified

The issue has been identified.

Although the issue is not within the emnify network (Telstra has recognized irregular behavior in their network and has taken measures to prevent a negative impact), we are in close contact with the responsible teams to resolve it as soon as possible
Posted Mar 26, 2025 - 09:48 UTC

Investigating

Dear emnify customer,

We are currently investigating a service degradation in Telstra Australia. Devices that attempt to connect to this network may experience issues.

We will publish a new update shortly.
Posted Mar 26, 2025 - 06:44 UTC
This incident affected: Network Connectivity (Network Connectivity - Asia-Pacific).