The incident has been resolved and the service is operational.
In case you are still experiencing issues, please submit a request to our Customer Support team.
Posted Aug 17, 2024 - 06:02 UTC
Monitoring
The service with MTN Uganda is restored, devices are already reconnecting to the network.
We will be monitoring this closely and we will publish a new update shortly
Posted Aug 17, 2024 - 05:39 UTC
Update
MTN Uganda has confirmed issues with their signalling carrier. While they work on a fix, we would like to remind you that the service with alternative networks (Airtel) is fully operational in the country.
Posted Aug 16, 2024 - 23:17 UTC
Identified
We confirm 2G/3G connectivity issues with MTN Uganda. 4G service remains operational, as well as the service with alternative networks in the country (Airtel).
We have contacted the operator, and we are waiting for a fix to be applied.
Posted Aug 16, 2024 - 12:52 UTC
Investigating
Dear emnify customer,
We are currently investigating a service degradation in MTN Uganda.
We will publish a new update shortly.
Posted Aug 16, 2024 - 12:35 UTC
This incident affected: Network Connectivity (Network Connectivity - Middle East & Africa).