Tigo Panama has confirmed that their 2G service has been permanently sunsetted. As a result, 2G connectivity is no longer available on the Tigo Panama network.
-Other radio access types with Tigo Panama remain available and are operating normally -2G service is still available in Panama through alternative mobile network
If you have any questions, please contact our Customer Support team.
Posted Feb 04, 2026 - 21:33 UTC
Identified
We have contacted Tigo Panama regarding the ongoing 2G service degradation and are currently awaiting their response.
In the meantime, please note: -3G and 4G services with Tigo Panama remain available and are operating normally -Alternative mobile networks in Panama are also available for connectivity fallback
Our team continues to monitor the situation closely and will provide further updates as soon as we receive additional information from the operator.
Posted Feb 04, 2026 - 21:13 UTC
Investigating
We are currently investigating reports of service degradation impacting 2G connectivity on the Tigo Panama network.
Further updates will be provided as more information becomes available.
Posted Feb 04, 2026 - 20:56 UTC
This incident affected: Network Connectivity (Network Connectivity - Central and South America & Caribbean).