Cellular service degradation in Spain and Portugal

Incident Report for emnify

Resolved

Dear emnify Customers,

After further monitoring, we confirm that the overall health of Spanish and Portuguese networks has returned to normal levels.

In case you are still experiencing issues, please reach out to our Customer Support Team via the help center.

Kind regards,
emnify Support Team
Posted Apr 30, 2025 - 02:08 UTC

Monitoring

Today we started to see that the overall health of Spanish and Portuguese networks is gradually returning to normal. Our tests also returned positive results.

We will continue to closely monitor.

Kind regards,
emnify Support Team
Posted Apr 29, 2025 - 12:47 UTC

Update

Our monitoring of these networks still shows instability, even though our tests of Spanish and Portuguese networks show positive results and we can see traffic flowing from and to these countries. We are closely monitoring the situation in Spain and Portugal, and we will publish a new update shortly.
Posted Apr 28, 2025 - 19:40 UTC

Identified

We have confirmed that the ongoing cellular service issues in Spain and Portugal are caused by a nationwide power outage in the said countries.

We will update you as soon as the situation progresses.

Kind regards,
emnify Support Team
Posted Apr 28, 2025 - 15:22 UTC

Investigating

Dear emnify Customers,

We are currently experiencing cellular service degradation in Spain and Portugal. Devices that attempt to connect to the networks in these 2 countries may experience issues.

We are investigating and we will publish a new update shortly.

Kind regards,
emnify Support Team
Posted Apr 28, 2025 - 12:36 UTC
This incident affected: Network Connectivity (Network Connectivity - Europe).