Mitigation measures have been applied, and current-month data is now available in the affected reports in the emnify portal.
While we continue restoring historical data, report filters are temporarily limited to the current month.
Our team will proceed with applying the recovery process for the affected time period and will continue to provide updates as progress is made.
Kind regards, emnify Support Team
Posted Jul 27, 2026 - 16:09 UTC
Identified
Dear emnify Customers,
Our team has identified the root cause of the issue and is currently working on implementing a fix.
We will continue to provide updates as progress is made.
Kind regards, emnify Support Team
Posted Jul 27, 2026 - 13:26 UTC
Investigating
Dear emnify Customers,
We are currently observing an issue affecting traffic data accuracy which may cause discrepancies in data usage statistics across the reports in the portal.
Our team is actively working to identify the cause and resolve the issue. We will share another update as soon as more information becomes available.
Kind regards, emnify Support Team
Posted Jul 27, 2026 - 13:15 UTC
This incident affects: Portal, API & Data Analytics (User Interface, Data Analytics).