Service Degradation - Airtel & Halotel Tanzania

Incident Report for emnify

Resolved

Connectivity in Tanzania has recovered. The country-wide network shutdown has ended and affected mobile network operators, including Airtel and Halotel, are operating normally again. Devices are now attaching and passing traffic as expected. We’ll continue to monitor for stability
Posted Nov 04, 2025 - 12:18 UTC

Identified

We are still observing a country-wide network shutdown in Tanzania, which appears to be affecting multiple mobile network operators, including Airtel and Halotel.
Devices attempting to connect to these networks may still experience complete loss of connectivity or degraded service.
Our team is closely monitoring the situation and will provide updates as soon as new information becomes available.
Posted Oct 31, 2025 - 11:20 UTC

Investigating

We are currently investigating a service degradation with Airtel & Halotel networks. Devices that attempt to connect to these networks may experience issues. Alternative networks are working as expected.
Posted Oct 29, 2025 - 15:47 UTC
This incident affected: Network Connectivity (Network Connectivity - Middle East & Africa).