Service degradation - MTN (Guinea-Bissau)

Incident Report for emnify

Identified

We are currently in contact with the operator and working with them while they implement corrective actions on their side to restore normal service.

Other mobile networks in Guinea-Bissau continue to operate normally and are not impacted.

We will continue to provide updates as more information becomes available.
Posted May 11, 2026 - 16:01 UTC

Investigating

We are currently investigating connectivity issues affecting devices connected through the MTN network in Guinea-Bissau. At this time, other mobile networks in the country are operating normally and are not impacted.

Further updates will be provided as more information becomes available.
Posted May 11, 2026 - 15:24 UTC
This incident affects: Network Connectivity (Network Connectivity - Middle East & Africa).